Les problèmes ADK et Eclipse – com.android.future et USBAccessory?

J'essaie d'obtenir l' option ADK (kit de développement d'accessoires) avec Eclipse, mais après avoir mis à jour l'API 12, pour exécuter le démoctement Hello World, j'ai les 29 erreurs, les premières étant les suivantes:

 Com.android.future ne peut pas être résolu, etc.
 UsbAccessory ne peut pas être résolu à un type

  • Android ProgressBar.setProgressDrawable ne fonctionne qu'une fois?
  • Le tiroir de navigation Android Studio, comme l'application Gmail
  • Comment puis-je détecter de façon dynamique si mon application est système ou normale?
  • MediaRecorder capture vidéo en mode portrait
  • Obtenir le nom de la classe enfant du parent
  • La classe PdfRenderer d'Android produit des images de mauvaise qualité
  • Didacticiel débutant pour Arduino Mega ADK
  • Un moyen approprié de fermer une connexion d'accessoire USB
  • Android ADK avec PC comme hôte USB avec libusb, erreur de transfert en vrac
  • Y compris d'autres projets Eclipse dans un projet d'application Android
  • Un tutoriel "Hello World" pour Arduino et Android
  • Build.xml donne des erreurs lors de la compilation d'un croquis de traitement qui comprend ArduinoAdkUsb
  • One Solution collect form web for “Les problèmes ADK et Eclipse – com.android.future et USBAccessory?”

    Vous devez définir votre cible de construction dans les API Google, et non sur Android. Cliquez sur Project-> Properties, puis dans la boîte de dialogue, sélectionnez Google API (2.3.3) au lieu de Android 2.3.3.

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.