La compilation AAPT2 a échoué: dimen invalide sur Android 3.0 Canary 1 sur Windows

J'ai ce problème après la mise à niveau AndroidStudio vers 3.0 Canary 1

Error:D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:911 invalid drawable Error:java.lang.RuntimeException: com.android.builder.internal.aapt.AaptException: AAPT2 compile failed: Error:Execution failed for task ':app:mergeDebugResources'. > Error: java.lang.RuntimeException: com.android.builder.internal.aapt.AaptException: AAPT2 compile failed: aapt2 compile -o D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\res\merged\debug D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml Issues: - ERROR: D:\Project\Freelance\Andoid\sosokan-android\sosokan-android\app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:911 invalid drawable 

Il semblerait que la compilation AAPT2 a échoué: dimen invalide sur Android 3.0 Canary 1 mais je ne trouve pas le moyen de le faire fonctionner sur Window

  • Comment maintenir la position de ListView
  • Impossible d'importer la classe de bibliothèque client Endpoints de google Cloud dans le projet Android
  • Android: désambiguïsage des chemins de fichiers
  • En essayant d'obtenir la taille d'affichage d'une image dans un ImageView
  • Comment puis-je créer le pied de page d'une extension ListView pour compléter l'espace restant?
  • J'ai une erreur: setOnItemClickListener ne peut pas être utilisé avec un spinner, qu'est-ce qui ne va pas?
  • Toute aide ou suggestion serait très appréciée.

    2 Solutions collect form web for “La compilation AAPT2 a échoué: dimen invalide sur Android 3.0 Canary 1 sur Windows”

    Avez-vous vu cette https://www.reddit.com/r/androiddev/comments/4u0gw1/support_library_2411_released/

    Si vous utilisez des bibliothèques de support sur la version 24.x (vous ou même vos dépendances), cela est incompatible avec AAPT2 et vous devez:

    • Disbale aapt2 dans votre fichier gradle.properties: android.enableAapt2=false
    • Ou mettre à niveau les bibliothèques google vers la version 25 ou 26

    @Phan Van Linh, pouvez-vous vérifier la ligne à partir de "values.xml: 911" où vous obtenez le problème non valable et google exactement?

    J'ai eu le même problème avec l'un de mes projets et la ligne problématique était:

     <item name="crop_image_menu_crop" type="drawable"/> 

    C'était à partir d'une bibliothèque d'images que j'avais utilisée dans mon projet. Le problème était que j'utilisais une ancienne version de la bibliothèque. Une fois que j'ai mis à jour la version plus récente, l'erreur est passée.

    J'espère que votre problème pourrait être réglé comme le mien.

    Bonne chasse!

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.