Impossible de résoudre les dépendances pour les outils SDK Android

Je ne peux pas installer Android SDK Tools sur Android Studio (version 2.3).

J'ai eu l'erreur suivante, Impossible de résoudre les dépendances pour les outils SDK Android

  • Adaptation 1.9 avec OkHttp 2.2 et intercepteurs
  • Lancer un script en tant que root via ADB
  • Signature pad est lent sur Android
  • Android NestedScrollView a une taille incorrecte après l'application: layout_behavior
  • Configurez Gson pour utiliser plusieurs formats de date
  • Programmation Scala pour Android
  • Est-ce que de toute façon, je peux résoudre cette erreur?

  • Android - Grow Heap (Frag Case) - Allocation de l'octet ... Pas de chargement de bitmaps
  • Ruby on android: ruboto vs rhodes?
  • Android Vision Barcode API - lisez un code QR personnalisé avec des données binaires
  • Android: détecte quand ScrollView arrête le défilement
  • Comment modifier la couleur de l'élément de liste Android sur le clic ou la sélection?
  • MPAndroidChart masquer la grille de fond
  • 6 Solutions collect form web for “Impossible de résoudre les dépendances pour les outils SDK Android”

    Google a réparé, côté du serveur, peu de temps après la découverte. Cela devrait fonctionner maintenant.

    TLDR; non.

    Google, pour quelque raison que ce soit, a décidé de supprimer l'accès direct au SDK Manager autonome à partir d'Android STudio v2.3. Si vous exécutez directement le gestionnaire SDK en utilisant les instructions de @ iK2H, vous verrez que le gestionnaire SDK ne détecte pas les Outils SDK de Windows v25.3.1. Il se pourrait que V25.3.1 soit uniquement disponible via les paramètres de Android Studio, mais cela est cassé pour l'instant.

    Votre meilleur avantage est de faire valoir cette question pour attirer l'attention sur Google pour la corriger.

    1. Ouvrir le terminal
    2. $ Cd "sdk path" / outils
    3. $ ./android
    4. Mettre à jour

    File -> Invalidate Caches / Restart or Build -> Clean Project peut vous aider (laissez-moi savoir s'il l'a fait)

    À partir de Windows, recherchez le SDK Manager et cliquez avec le bouton droit de la souris pour "exécuter en tant qu'administrateur". Essayez d'installer à partir de là.

    A eu le même problème et cela a fonctionné pour moi …

    Ok, je pense que j'ai trouvé la solution. Veuillez l'essayer et faire rapport sur les commentaires. Build est un succès, mais j'ai toujours besoin de tester par application pour vérifier les fonctionnalités et autres effets secondaires possibles. Je ne voulais pas que tout le monde attende jusqu'à ce que cela soit résolu. Si cela ne fonctionne pas ou a de sérieux problèmes, je suis heureux de supprimer cette réponse.

    COMMENTEZ S'IL VOUS PLAÎT

    La solution

    1. J'ai commenté

      Compile 'com.google.android.gms: play-services: xyz'

    2. J'ai également supprimé

      Com.google.android.gms: play-services-appindexing com.google.android.gms: play-services-contextmanager

    3. Mise à niveau des autres com.google.android.gms:* services vers 10.2.0

    C'est mon build.gradle travail sans erreur

     apply plugin: 'com.android.application' android { compileSdkVersion 25 buildToolsVersion '25.0.2' defaultConfig { minSdkVersion 16 targetSdkVersion 25 multiDexEnabled = true } def applicationVersion = '*****' dexOptions { // incremental = true; // If anybody use below 2.2.2 android studio then please uncomment this line. It's by default true. preDexLibraries = false javaMaxHeapSize "2g" } signingConfigs { .... } buildTypes { ... } productFlavors { ... } packagingOptions { ... } } dependencies { testCompile 'junit:junit:4.12' compile 'com.android.support:support-v4:25.1.1' // compile 'com.google.code.gson:gson:2.2.4' compile 'com.fasterxml.jackson.core:jackson-core:2.6.1' compile 'com.fasterxml.jackson.core:jackson-annotations:2.6.1' compile 'com.fasterxml.jackson.core:jackson-databind:2.6.1' compile 'com.android.support:appcompat-v7:25.1.1' compile 'com.android.support:design:25.1.1' compile 'com.crittercism:crittercism-android-agent:+' compile 'com.android.support:multidex:1.0.1' compile 'com.google.android.gms:play-services:10.2.0' compile 'com.google.android.gms:play-services-base:10.2.0' // compile 'com.google.android.gms:play-services-appindexing:10.2.0' // compile 'com.google.android.gms:play-services-contextmanager:10.2.0' compile 'com.google.android.gms:play-services-places:10.2.0' compile 'com.google.android.gms:play-services-nearby:10.2.0' compile 'com.google.android.gms:play-services-maps:10.2.0' // compile 'com.google.android.gms:play-services-ads:10.2.0' // compile 'com.google.android.gms:play-services-auth:10.2.0' compile 'com.google.android.gms:play-services-gcm:10.2.0' compile 'com.google.android.gms:play-services-analytics:10.2.0' compile 'com.google.android.gms:play-services-location:10.2.0' // compile 'com.google.android.gms:play-services-awareness:10.2.0' // compile 'com.google.android.gms:play-services-cast:10.2.0' // compile 'com.google.android.gms:play-services-plus:10.2.0' compile 'com.google.maps.android:android-maps-utils:0.4.+' compile 'com.google.zxing:core:3.2.0' compile 'com.journeyapps:zxing-android-embedded:3.3.0@aar' compile 'com.google.firebase:firebase-messaging:10.2.0' compile 'com.google.firebase:firebase-core:10.2.0' compile 'com.google.firebase:firebase-analytics:10.2.0' compile 'com.flurry.android:analytics:6.4.2' .... } apply plugin: 'com.google.gms.google-services' 
    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.