Impossible de résoudre la cible 'android-21'

J'ai le dernier plugin ADT pour eclipse: ADT-23.0.4 .
Version Eclipse: Luna Service Release 1 (4.4.1) .

Je reçois toujours cette erreur lors de l'importation d'un projet:

  • Accès à Microsoft Band SDK (PC et Android)
  • BitmapFactory.decodeStream hors mémoire malgré l'utilisation d'une taille d'échantillon réduite
  • Un bon tutoriel pour l'utilisation de AccountManager dans Android?
  • Google Analytics pour Android. Les utilisateurs qui reçoivent des notifications sont comptés comme actifs
  • Taille de l'image de l'appareil photo Android
  • La base de données sqlite android est bloquée "malgré l'utilisation du fournisseur de contenu et l'accès séquentiel à la base de données
  • Impossible de résoudre la cible 'android-21'

  • Inclure les dépendances de maven dans eclipse "Exécuter comme -> application Android" build
  • Obtenir tous les éléments d'un ArrayAdapter
  • Commandes personnalisées pour Google Now
  • Android Sauvegarder l'image sur la carte SD
  • Android: ViewPager est bloqué entre les vues
  • ViewPager dans l'élément de ligne ListView
  • 2 Solutions collect form web for “Impossible de résoudre la cible 'android-21'”

    Cliquez avec le Project -> Properties -> android droit sur Project -> Properties -> android -> choisissez votre niveau d'api cible que vous avez, puis appuyez sur Appliquer et Ok

    Et nettoyer le projet une fois et le reconstruire.

    Accédez à Windows -> Android SDK Manager Installez le niveau d'API Android que vous souhaitez, dans ce cas 21.

    Une fois que vous avez terminé l'installation, passez à Window -> Preference -> Android . Vous devriez obtenir une liste des cibles disponibles. Cliquez sur Appliquer puis sur OK .

    Maintenant, cliquez avec le bouton droit sur votre projet, accédez aux propriétés. Cliquez sur Android. Choisissez la cible souhaitée.

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.