Exécution de l'erreur de diagnostic GTM

Lorsque j'essaie de nettoyer mes projets Android dans Eclipse, j'obtiens toujours cette erreur:

An internal error occurred during: "Running GTM diagnose". com.android.tools.lint.detector.api.XmlContext: method <init>(Lcom/android/tools/lint/client/api/LintDriver;Lcom/android/tools/lint/detector/api/Project;Lcom/android/tools/lint/detector/api/Project;Ljava/io/File;Lcom/android/resources/ResourceFolderType;)V not found 

Toute aide serait très appréciée.

4 Solutions collect form web for “Exécution de l'erreur de diagnostic GTM”

Je viens de désinstaller l'ATM ( Android Translation Manager ) et l'erreur disparaît.

Dans Eclipse, accédez à -> Aide -> Détails de l'installation -> Sélectionnez l'ATM et cliquez sur Désinstaller .

Redémarrez eclipse et DONE .

Au moins pour moi, le message d'erreur est disparu .

Je pense que j'ai résolu le problème. Après la mise à jour vers ADT v23 j'ai installé Android Translation Manager aussi que je n'ai jamais utilisé auparavant. J'ai déplacé mon strings.xml vers le dossier values-en et je n'ai jamais reçu ce message. Séparer les langues du dossier des values résolu le problème, mais je pense que peut-être devrait-il être causé par Android Translation Manager, peut-être un bug, mais je devrais exécuter plus de tests ….

C'est probablement parce que votre fichier de chaîne déclenche l'erreur "Traduction manquante" dans Android Lint. Cette erreur signifie qu'il existe des chaînes dans votre fichier de chaîne qui ne sont pas traduits dans d'autres langues. Pour arrêter les fenêtres contextuelles, cliquez avec le bouton droit de la souris sur votre projet Android -> propriété -> Préférences de peluches Android -> Modifiez la gravité de "Traduction manquante" en cas d'erreur.

D'accord, j'ai commencé à m'employer des erreurs et j'ai finalement trouvé quelque chose qui semble avoir fonctionné et, en fait, cela a du sens compte tenu des problèmes. Cela a fonctionné pour moi, donc j'espère que vous obtenez le même succès. Lorsque j'ai mis à jour la version la plus récente de l'Android, mes paramètres pour eclipse ont eu des problèmes existants. J'ai supprimé le fichier .settings pour eclipse, puis réglé la mise en place d'un plus de problèmes.
AVERTISSEMENT L'EXÉCUTION DU FICHIER DE RÉGLAGES REPRENDRE LES THÈMES JUSQU'À CE QUE VOUS LES RECONFECTONS, JE SUIS LES ÉTAPES QUE VOUS DEVEZ SUIVRE

  1. Accédez à (en supposant Windows) C: \ ProgramFiles \ Eclipse \ configuration \ et supprimez .settings . Pour d'autres machines, accédez au répertoire d'installation elipse.
  2. Relauch eclipse. (Tout sera brisé, d'accord) Si vous n'êtes pas cassé, faites les mêmes étapes.
  3. Ouvrir à partir de la barre de menu
    Projet -> Propriétés -> Compilateur Java
  4. Assurez-vous que l' activation des paramètres spécifiques au projet n'est PAS cochée
  5. Accédez à l'explorateur de projet et cliquez avec le bouton droit de la souris sur le projet racine et allez à:
    Outils Android -> Réparer les propriétés du projet (cela corrigera et les erreurs existantes qui pourraient avoir été reportées)
  6. Si vous avez plusieurs versions d'installation Java, continuez, sinon vous devriez le faire
  7. Ouvert de la barre de menus
    Fenêtre -> Préférences -> Java -> JREs installés Assurez-vous qu'il est défini sur le plus récent
  8. Ouvert de la barre de menus
    Fenêtre -> Préférences -> Java -> Compilateur Utiliser les paramètres par défaut

Ensuite, créez simplement une version propre et cela devrait fonctionner très bien. J'espère que cela fonctionne pour toi.

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.