Erreur de construction Gradle: Impossible de charger les méta-données Maven à partir de https://repo1.maven.org/maven2/io/fabric/tools/gradle/maven-metadata.xml

Je reçois une erreur de génération de gradle dans Android studio comme ci-dessous:

Error:A problem occurred configuring project ':MyApp'. Could not resolve all dependencies for configuration ':MyApp:classpath'. Could not resolve io.fabric.tools:gradle:1.+. Required by: sw-android:MyApp:unspecified Failed to list versions for io.fabric.tools:gradle. Unable to load Maven meta-data from https://repo1.maven.org/maven2/io/fabric/tools/gradle/maven-metadata.xml. Could not GET 'https://repo1.maven.org/maven2/io/fabric/tools/gradle/maven-metadata.xml'. peer not authenticated Failed to list versions for io.fabric.tools:gradle. Unable to load Maven meta-data from http://maven.fabric.io/public/io/fabric/tools/gradle/maven-metadata.xml. Could not GET http://maven.fabric.io/public/io/fabric/tools/gradle/maven-metadata.xml'. peer not authenticated 

J'ai trouvé que "https" Tag ne fonctionne pas pour télécharger l'URL de Maven, donc j'ai changé la https à http dans mon fichier build.gradle. Aussi, j'ai vérifié tous les réglages de gradle et modifie manuellement le fichier other.xml dans le chemin C: \ Users \ Ashfaque1.AndroidStudio \ config \ options \ mais il est encore en train de prendre la https://repo1.maven.org/maven2/io /fabric/tools/gradle/maven-metadata.xml . Une fois que je suis en train de frapper ce lien vers le navigateur, je reçois l'exception 404, mais la 2ème URL dans l'erreur http://maven.fabric.io/public/io/fabric/tools/gradle/maven-metadata.xml , je suis Capable de réussir et de télécharger correctement le fichier Metadata dans mon système. Pas capable de comprendre quel est le problème, où j'ai besoin de modifier les paramètres afin que le fichier de métadonnées soit téléchargé. Veuillez suggérer si j'ai besoin de changer les paramètres ou d'où il prend cette URL https://repo1.maven.org/maven2//io/fabric/tools/gradle/maven-metadata.xml

  • ADB lance SecurityException tout en démarrant le service après la mise à jour du système vers Nexus 7: "L'appelant uid = 2000 n'a pas le privilège de communiquer avec l'utilisateur = -2"
  • Copier un tampon d'octets avec JNI
  • ClassNotFoundException pour com.facebook.FacebookActivity
  • Comment éviter les fuites Eclipse sur XServer lors de l'édition de fichiers XML Android?
  • Comment obtenir un service "bound" Android pour survivre à un redémarrage de la configuration
  • Dagger 2 "Dagger" préfixe composant pas capable de compiler? Classe générée automatiquement
  • Mon fichier build.gradle est comme ci-dessous:

      apply plugin: 'com.android.application' apply plugin: 'io.fabric' buildscript { repositories { mavenCentral() maven { url 'http://maven.fabric.io/public' } } dependencies { classpath 'com.android.tools.build:gradle:1.1.0' classpath 'io.fabric.tools:gradle:1.+' } } repositories { mavenCentral() maven { url 'http://maven.fabric.io/public' } } dependencies { compile 'com.android.support:multidex:1.0.0' compile fileTree(dir: 'libs',include: '*.jar') compile project(':DeviceService') compile project(':RatioCommon') compile project(':SlidingMenu:library') compile project(':SmartViewLibrary:SmartView') compile project(':SmartViewLibrary:OpenAccess') compile('com.crashlytics.sdk.android:crashlytics:2.2.0@aar') { transitive = true; } } compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { minSdkVersion 18 targetSdkVersion 21 // Enabling multidex support. multiDexEnabled true } dexOptions { javaMaxHeapSize "4g" } } 

  • Les ondulations ne s'affichent pas avec selectableItemBackground comme premier plan sur un CardView avec un appareil Android 5.0
  • La géolocalisation de phonegap échoue toujours sur le délai d'attente
  • Comment faire mon application en plein écran sur l'onglet Galaxy
  • Android Studio: Création de mises en page de paysage
  • Comment exactement l'android: l'attribut onClick XML diffère de setOnClickListener?
  • MalformedJsonException with Retrofit API?
  • 2 Solutions collect form web for “Erreur de construction Gradle: Impossible de charger les méta-données Maven à partir de https://repo1.maven.org/maven2/io/fabric/tools/gradle/maven-metadata.xml”

    1) Vous devez synchroniser avec des remises à distance, avec quelque chose comme

    mvn install - U

    Ou dans Android Studio ou IntelliJ Idea accédez à Settings trouvez le groupe Maven , trouvez les Repositories sous-groupes et cliquez sur Update à Update le compte de pièces.

    Entrez la description de l'image ici

    2) Si cela ne vous aide pas, passez à jcenter() plutôt mavenCentral() , car les développeurs fabric.io qui poussent les mises à jour vers jcentral() et mavenCentral() peuvent être dépassés. En savoir plus sur la différence entre deux: les référentiels de buildscript Android: jcenter VS mavencentral

    Cela peut se produire lorsque vous êtes derrière un proxy

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.