Crouton dépend des bibliothèques mais n'est pas une bibliothèque elle-même

J'utilise Android Studio 0.6.1, avec la bibliothèque Crouton et aujourd'hui après la synchronisation gradle, j'ai eu la prochaine erreur:

Error:A problem occurred configuring root project 'project_name'. Module version de.keyboardsurfer.android.widget:crouton:1.8.4 depends on libraries but is not a library itself 

Cela se passe-t-il?

  • Devrais-je importer android.graphics.camera ou android.hardware.camera?
  • Comment puis-je obtenir Android Studio pour arrêter de renvoyer le code généré dans les résultats de recherche?
  • GPS VS accéléromètre pour calculer la distance
  • Y a-t-il des API / exemples / didacticiels officiels pour la mise en œuvre des nouvelles directives Material-Design?
  • Android WebView UTF-8 ne s'affiche pas
  • MultiAutoCompleteTextView avec modifications de l'adaptateur dynamique
  • Comment ajouter automatiquement des milliers de séparateurs lorsque le numéro est entré dans EditText
  • Comment implémenter l'onglet de navigation inférieur selon la nouvelle ligne directrice de google
  • Force Parse Push Notifications pour utiliser PPNS au lieu de GCM
  • Pourquoi il lance parfois FileNotFoundException
  • Comment enregistrer l'entrée dans le calendrier natif (Android et iOS) dans une réaction native?
  • Affichage de plusieurs itinéraires à l'aide de l'API Directions dans Android
  • 2 Solutions collect form web for “Crouton dépend des bibliothèques mais n'est pas une bibliothèque elle-même”

    Ce problème en raison de la mise à jour récente com.android.support-v4.

    J'ai donc changé

     compile 'com.android.support:support-v4:20.+' 

    à

     compile 'com.android.support:support-v4:19.1.+' 

    Et crouton fonctionne bien

    Une solution de contournement différente consiste à utiliser @aar:

     compile('de.keyboardsurfer.android.widget:crouton:1.8.4@aar') { exclude group: 'com.google.android', module: 'support-v4' } 

    Ma solution selon @Revedko répond, en utilisant @aar et changez tous les supports à une version inférieure à 21 -> 20. +

     dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.loopj.android:android-async-http:1.+' compile "com.bugsense.trace:bugsense:3.5" compile('de.keyboardsurfer.android.widget:crouton:1.8.4@aar') { exclude group: 'com.google.android', module: 'support-v4' } compile 'com.android.support:appcompat-v7:20.+' compile 'com.google.android.gms:play-services:5.0.77' } 
    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.