Comment importer une bibliothèque distante dans Android Studio en utilisant gradle?

J'essaie d'importer Android-Swipelistview ( https://github.com/47deg/android-swipelistview ) dans mon module Android Studio en utilisant gradle. Ne devrait-il pas être possible avec build.gradle config seul? Est-ce que quelqu'un a un fichier de configuration qui effectue le travail?

  • Où sont les démonstrations de l'API Android?
  • Empêchez-vous recharger WebView dans FragmentPagerAdapter?
  • Essayer de transférer POI d'Apache vers Android
  • La version des outils de plate-forme SDK ((23)) est trop ancienne pour vérifier les API compilées avec API 23
  • Utilisation de la couleur et color.darker dans Android?
  • Comment utiliser les chaînes formatées avec les espaces réservés dans Android?
  • Fini avec une valeur de sortie non nulle
  • Minimiser Android GLSurfaceView lag
  • Comment le système Android Keystore peut-il être sécurisé?
  • Pourquoi la même interface est-elle diffusée différemment sur un émulateur et un périphérique?
  • Surfaceview + glsurfaceview + framelayout
  • Causé par: java.lang.OutOfMemoryError: la taille du bitmap dépasse le budget VM
  • 3 Solutions collect form web for “Comment importer une bibliothèque distante dans Android Studio en utilisant gradle?”

    Vous pouvez utiliser:

    compile 'com.nineoldandroids:library:2.4.0' 

    Ou si vous avez copié la bibliothèque dans votre répertoire de bibliothèque de projets, vous pouvez utiliser:

     compile files ('libs/ nineoldandroids-2.4.0.jar') 

    Cependant, vous pouvez consulter mon article sur le démarrage de swipelistview: http://modewagon.wordpress.com/2013/09/16/getting-started-with-swipelistview/

    J'avais une erreur sur la résolution de l'erreur sur cette bibliothèque. La correction pour moi était, dans le fichier build.gradle , de modifier ceci:

     repositories { mavenCentral() } 

    pour ça:

     repositories { jcenter { url "http://jcenter.bintray.com/" } } 

    Si compile 'com.nineoldandroids: library: 2.4.0+' ne fonctionne pas,

    Essayez ceci -> compile 'com.nineoldandroids: library: 2.4. +'

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.