Tag: gradle

L'apk résultant de la compilation Android Gradle comporte à la fois des classes obscènes et non obscures

Lors de la construction de mon projet Android, j'ai ajouté ce qui suit au fichier build.gradle pour permettre à proguard: buildTypes { release { runProguard true proguardFile 'proguard-project.txt' proguardFile '../common/proguard-shared.txt' proguardFile getDefaultProguardFile('proguard-android.txt') } } Tout s'ajuste, mais quand je démonte le fichier dex résultant, il s'avère que les fichiers obscènes et non obscures sont là. […]

Gardez une commande de dépendances spécifique pour Android Studio

J'essaie d'exécuter des tests unitaires avec Robolectric dans Android Studio. Je suis presque là – je vois: !!! JUnit version 3.8 or later expected: java.lang.RuntimeException: Stub! at junit.runner.BaseTestRunner.<init>(BaseTestRunner.java:5) at junit.textui.TestRunner.<init>(TestRunner.java:54) at junit.textui.TestRunner.<init>(TestRunner.java:48) at junit.textui.TestRunner.<init>(TestRunner.java:41) at com.intellij.rt.execution.junit.JUnitStarter.junitVersionChecks(JUnitStarter.java:185) … Je vois aussi toutes les dépendances requises dans le chemin de classe. Pour corriger cette erreur, je dois […]

Problèmes liés aux tests d'instruments Espresso sur les périphériques d'exécution Dalvik

Je cours sur un problème similaire à FragmentActivity ne peut pas être testé via ActivityInstrumentationTestCase2 Le problème avec la solution supérieure est que cela s'applique uniquement à l'utilisation du système de construction Eclipse. J'utilise Gradle pour mon projet. Sur mon Nexus 5 exécutant le temps d'exécution ART, mes tests d'instruments Espresso fonctionnent parfaitement. Lorsque j'utilise […]

Studio Android 2.3 projet de gradle rafraîchissant prenant pour toujours

J'ai mis à jour mon studio Android jusqu'à la nouvelle version 2.3 et j'ai été invité à convertir mon projet pour faire correspondre les nouveaux formats que j'ai faits. On m'a demandé de mettre à jour la version de gradle et je l'ai fait. Maintenant une éternité plus tard, elle rafraîchit mon projet gradle. Je […]

Gradle kotlin Méthode non prise en charge Dependencies.getAtoms ()

Il vient de commencer un nouveau projet Android avec Studio 3.0 Canary 3 en utilisant kotlin et essaye juste de l'obtenir pour effectuer une synchronisation de projet gradle. Actuellement en panne avec Error:Unsupported method: Dependencies.getAtoms(). The version of Gradle you connect to does not support that method. To resolve the problem you can change/upgrade the […]

Erreur: le projet utilise une version non prise en charge du plug-in Android Gradle (0.12.2)

Après la mise à jour Android Studio, je ne peux pas exécuter mon application – j'obtiens cette exception: Error:The project is using an unsupported version of the Android Gradle plug-in (0.12.2). The recommended version is 1.0.0-rc4. Ce sont mes dépendances de buld.gradle dependencies { classpath 'com.android.tools.build:gradle:0.12.+' classpath 'com.crashlytics.tools.gradle:crashlytics-gradle:1.+' } MISE À JOUR J'ai changé dans […]

Android – Quelle est la différence entre compileSDKVersion "Google Inc.: API de Google: 22" et "22"?

Dans le fichier Gradle.build, je vois certains projets en utilisant CompileSdkVersion = "Google Inc.: API de Google: 22" Et certains utilisent simplement le numéro CompileSdkVersion = "22" Quelle est la différence entre les deux?

Est-il possible d'intégrer Dagger et AspectJ dans un projet Android Studio?

Je travaille dans un projet Android où j'utilise Dagger pour l'injection de dépendance. Je ne sais pas grand-chose sur Gradle, mais dans la mesure où je comprends, les annotations de Dagger sont traitées par son compilateur une fois que le projet a été construit. Il n'y a aucun problème à configurer comme l'indique le guide […]

Le projet ne peut pas être compilé après la mise à niveau vers Gradle: 2.1.0-alpha5

J'ai un projet Android qui fonctionnait parfaitement avec les versions pré-gradle: 2.1.0-alpha3. Maintenant, il lance ces types d'erreurs sans aucun indice de la façon de les résoudre: Error:Execution failed for task ':app:compileDebugJavaWithJavac'. > java.lang.NoSuchMethodError: com.google.common.collect.FluentIterable.append(Ljava/lang/Iterable;)Lcom/google/common/collect/FluentIterable; C'est assez étrange, il y a une branche particulière qui, pour les quatre ou cinq derniers jours, a également utilisé […]

Studio Android important dans un problème gradle

Je suis nouveau sur Android Studio et essayais simplement d' importer mon projet eclipse . J'essaie de résoudre ce problème depuis un bon moment maintenant mais impossible. J'ai un projet de l'activité principale qui utilise les autres bibliothèques d'autres bibliothèques décalées, devsmart, google maps et appcompactv7 . Je reçois 2 erreurs. Remarque: le projet de […]

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.