Tag: Android studio

Impossible de résoudre la classe dans build.gradle en utilisant Android Studio 0.60 / Gradle 0.11

Une application établie fonctionne bien avec Android Studio 0.5.9 / Gradle 0.9 mais la mise à niveau vers Android Studio 0.6.0 / Gradle 0.11 provoque l'erreur ci-dessous. D'une certaine manière, Studio semble avoir perdu la capacité de résoudre les importations d'outils Android en haut du fichier build.gradle. Quelqu'un a-t-il des idées sur la façon de […]

Android Studio Signed APK ': application: transformClassesAndResourcesWithProguardForRelease'

Lorsque j'essaie de générer signé dans Android Studio, j'ai l'erreur suivante: Erreur: l'exécution a échoué pour la tâche ': application: transformClassesAndResourcesWithProguardForRelease'. Java.io.IOException: corrigez d'abord les avertissements ci-dessus. Déjà faites des recherches et découvrez cela par exemple: Erreur: échec de l'exécution pour la tâche ': android: transformClassesAndResourcesWithProguardForRelease' J'ai suivi les conseils, cela n'a pas fonctionné. Alors, […]

Play_licensing lance une erreur AIDL avec downloader_library pour APK Expansion avec Gradle

J'ai essayé d'utiliser le fichier zip d'APK Expansion et la bibliothèque downloader_library (qui nécessite play_licensing). Zip_file a bien fonctionné car il n'a pas de dépendances, mais play_licensing lance une erreur lorsque j'essaie d'une synchronisation Gradle. Android Studio craque ce journal des erreurs: Information:Gradle tasks [:app:generateGoogleDebugSources, :app:libs:downloader_library:generateDebugSources, :app:libs:play_licensing:generateDebugSources, :app:libs:zip_file:generateDebugSources] Information:/Users/faiz/Projects/Android/TogetherTime/app/libs/play_licensing/aidl/ILicenseResultListener.aidl:21 interface ILicenseResultListener should be declared in […]

Capture d'écran Android / Android Studio 0.8 Beta cassée

J'ai mis à niveau Android Studio de 0.6.2 à 0.8 beta hier soir, sans problème. Malheureusement, j'ai essayé de saisir une capture vidéo de Glass (j'envoie régulièrement des mises à jour de progrès) pour trouver que ça ne fonctionne plus. En appuyant sur l'enregistrement, il ignore le processus d'enregistrement réel et passe directement à la […]

Dependency org.json: json: 20090211 est ignoré pour debug car il peut être en conflit avec la version interne fournie par Android

Pendant que je cours sur le studio Android, l'avertissement ci-dessous apparaît: Dependency org.json: json: 20090211 est ignoré pour debug car il peut être contradictoire avec la version interne fournie par Android. En cas de problème, remballer avec jarjar pour changer les paquets de classe Comment puis-je résoudre cette erreur? Je vous remercie.

Exclure .jar de la compilation dans Android Studio avec Gradle

J'ai actuellement quelque chose comme ça dans le fichier build.gradle. dependencies { compile 'com.android.support:support-v4:13.0.+' compile ('com.xxx:xxx-commons:1.+') { } } Un problème survient puisque jUnit et hamcrest-core sont présents dans le référentiel maven com.xxx:xxx, créant ainsi une erreur: Gradle: Origin 1: /Users/yyy/.gradle/caches/artifacts-26/filestore/junit/junit/4.11/jar/4e031bb61df09069aeb2bffb4019e7a5034a4ee0/junit-4.11.jar Gradle: Origin 2: /Users/yyy/.gradle/caches/artifacts-26/filestore/org.hamcrest/hamcrest-core/1.3/jar/42a25dc3219429f0e5d060061f71acb49bf010a0/hamcrest-core-1.3.jar Gradle: Execution failed for task ':android:packageDebug'. > Duplicate files copied […]

Quelle est la version de plugin Android incluse dans IntelliJ IDEA?

… et comment le découvrir (de manière autonome)? Dans Android Studio 0.8.11: lorsque je vérifie la même chose, il affiche 10.0.8.11. Qui correspond à http://tools.android.com/recent et http://developer.android.com/sdk/installing/studio.html . Dans IDEA EAP 14: quand je vais à Paramètres> Plugins> Support Android, le numéro de version affiché est 10.0 qui ne correspond pas à une version récente […]

Créer un projet de bibliothèque STANDALONE Android Studio (1.5)

Je dois créer la bibliothèque Android et livrer la version finale. Jar fichier aux clients. Je suis nouveau sur Android (trois jours). Je fais iOS depuis 4 ans. Je suis passé par la documentation officielle de Google et des tutoriels pour avoir une idée de la plate-forme (je ne veux pas qu'il soit évident qu'un […]

Comment ajouter un bouton d'action flottante en haut de scrollview

J'ai un bouton d'action flottante que j'aimerais ajouter au dessus d'une vue de défilement afin que le bouton reste, même si vous faites défiler. Je le veux sur le dessus du scrollview et dans le coin inférieur droit de l'écran. Quelle combinaison de vues dois-je utiliser pour accomplir cela? Voici le fichier xml: <RelativeLayout xmlns:android="http://schemas.android.com/apk/res/android" […]

Plusieurs dépôts maven à Gradle

J'ai le build.gradle suivant: buildscript { repositories { maven { url 'https://maven.fabric.io/public' } maven { url "https://dl.bintray.com/fyber/maven" } maven { url "https://dl.bintray.com/supersonic/android-sdk" } } dependencies { classpath 'io.fabric.tools:gradle:1.19.1' } } apply plugin: 'com.android.application' apply plugin: 'io.fabric' apply plugin: 'com.google.gms.google-services' dependencies { // Ads compile 'com.supersonic.sdk:mediationsdk:6.1.0@jar' } Et j'obtiens cette erreur: Erreur: (88, 13) Impossible de […]

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.