Tag: android gradle

Impossible de résoudre: com.google.android.gms: play-services-cast: 9.8.00

J'utilise Android Studio et j'ai cloné l' application de référence CastVideo v2 et la configuré avec CastCompanionLibrary selon ses instructions. Cependant, lorsque j'essaie de synchroniser le projet gradle, il dit: Failed to resolve: com.google.android.gms:play-services-cast:9.8.00 . J'ai l'option d' Install Repository and sync project mais il ne fait rien. J'ai essayé de faire Invalidate Caches / […]

Erreur dans les valeurs générées – fichier 23 dans Android

Je reçois cette erreur lorsque j'essaie de construire mon projet. Error:(3, 5) No resource found that matches the given name (at 'cardBackgroundColor' with value '?android:attr/colorBackgroundFloating'). Error:Execution failed for task ':app:processDebugResources'. com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Users\Home\AppData\Local\Android\sdk\build-tools\23.0.2\aapt.exe'' finished with non-zero exit value 1 Et quand je clique dessus, il me prend le fichier de valeurs v-23 du […]

Impossible de trouver la cible avec la chaîne de hachage 'android-24'

Je reçois cette erreur après avoir changé toutes les bibliothèques Google en 24.0.0 et en changeant compileSdkVersion et targetSdkVersion en 24. Comme vous pouvez le voir dans les images ci-jointes, j'ai installé tous les paquets Android N, mais il n'y a que des positions: "Partiellement installé". Comment puis-je réparer cela?

Butterknife 8.4.0 – Plugin avec id 'android-apt' introuvable

Je continue d'obtenir l'erreur Le Plugin with id 'android-apt' not found . Qu'est-ce qui ne va pas ici? plugins { id "me.tatarka.retrolambda" version "3.2.5" } apply plugin: 'com.android.application' apply plugin: 'android-apt' android { compileSdkVersion 24 buildToolsVersion '23.0.3' dexOptions { javaMaxHeapSize "6g" } defaultConfig { applicationId "com.yitter.android" minSdkVersion 15 targetSdkVersion 24 multiDexEnabled true // Enabling multidex […]

Android Gradle – configuration de la signature de chargement à partir d'un fichier externe

Dans Gradle pour Android, il semble que les commons pratiquent pour définir votre configuration de signature pour la version de version comme ceci: android { signingConfigs { debug { storeFile file("debug.keystore") } myConfig { storeFile file("other.keystore") storePassword "android" keyAlias "androiddebugkey" keyPassword "android" } } buildTypes { foo { debuggable true jniDebugBuild true signingConfig signingConfigs.myConfig } […]

Build Failure sur Android Studio

Après avoir mis à jour toutes les bibliothèques de support de Google vers les dernières versions, de v21 à v22.2.0 et Play Services vers v7.5, mon projet ne se construit plus avec succès. Le journal que je reçois est le suivant: app:preDexDebug AGPBI: {"kind":"simple","text":"Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar ","sources":[{}]} AGPBI: {"kind":"simple","text":"Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar ","sources":[{}]} AGPBI: […]

Erreur lors de l'exécution de réactive-native run-android –variant = release (Task 'installReleaseDebug' n'est pas trouvé dans le projet racine 'gnosisapp').

J'essaie d'essayer de react-native run-android –variant=release Starting JS server… Running /home/sonic182/Android/platform-tools/adb -s ZY2232QD4K reverse tcp:8081 tcp:8081 Building and installing the app on the device (cd android && ./gradlew installReleaseDebug)… FAILURE: Build failed with an exception. * What went wrong: Task 'installReleaseDebug' not found in root project 'gnosisapp'. * Try: Run gradlew tasks to get a […]

Comment définir mon gradle pour la version finale apk

Plus tôt, mon diplôme était comme suit: QUELLE EST INCORRECTE INCORRECTE apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion '19.0.3' defaultConfig { minSdkVersion 11 targetSdkVersion 19 versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:gridlayout-v7:19.0.1' compile 'com.android.support:appcompat-v7:+' compile fileTree(dir: 'libs', include: ['*.jar']) compile […]

Définissez une variable globale dans gradle qui peut être utilisée dans un fichier manifeste

Je souhaite créer une variable globale similaire à applicationId. Il est défini dans build.gradle et sera utilisé dans le manifeste. C'est possible?

Dagger 2, Gradle Plugins et Jack – Instructions requises

J'utilise Dagger 2 (premier utilisateur de la bibliothèque DI) avec Android Studio (AS 2.1.2 – SDK 24) et, évidemment, ma première pensée est "Quelles dépendances ai-je besoin pour l'utiliser?" Après avoir examiné les exemples que je peux voir que vous avez besoin dans le fichier build.gradle niveau build.gradle , vous avez besoin d'un plugin de […]

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.