Tag: android gradle

Utilisez MultiDexEnabled sans Gradle, mais le processus de construction Eclipse à la place

Depuis la dernière version de SDK, il est beaucoup plus simple de créer des applications avec plusieurs fichiers dex ( https://developer.android.com/tools/building/multidex.html ), ma question est, cette nouvelle fonctionnalité peut-elle également être utilisée lorsque je Je n'utilise pas Gradle pour le processus de construction, mais la "ancienne" chaîne de construction Eclipse? Le "multiDexEnabled true" dans le […]

Impossible de créer une application Erreur: échec d'exécution pour la tâche ': application: package "packageName" Debug ". > Valeur (73836)> 0x0000ffff

Impossible de créer une application. La compilation a échoué: Error:Execution failed for task ':app:package "packageName" Debug'.> value (73836) > 0x0000ffff Le projet est généré avec succès, mais l'ajout d'une ligne de code (Log.i ()) reçoit un message de compilation échoué, après le redémarrage (invalidate caches) fonctionne comme prévu Gradle-wrapper.properites distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-2.12-all.zip Voici […]

Utilisez le plugin DataBinding Android parallèlement au plugin GoogleServices

Est-ce que quelqu'un était capable d'utiliser le plugin Android DataBinding parallèlement à Google Services pluginplugin? dependencies { classpath 'com.android.tools.build:gradle:1.3.1' classpath 'com.google.gms:google-services:1.4.0-beta3' classpath 'com.android.databinding:dataBinder:1.0-rc1' } apply plugin: 'com.google.gms.google-services' apply plugin: 'com.android.databinding' Ensuite, tout le projet vient d'exploser. Lorsque je supprime le plugin de services, la liaison de données fonctionne. C'est la piste d'attelage de Gradle. [data […]

Flux de produit Android versionNameSuffix

J'utilise buildTypes et ProductFlavors. Mon application utilise également un outil d'analyse et cet outil a utilisé la versionName de mon application. Comment modifier la versionName par saveur? Mon test était productFlavors { google { versionNameSuffix ".google" } } Mais il a échoué. Est-ce que quelqu'un a une idée de comment personnaliser la versionName en fonction […]

Gradle cherche aar dans le dossier lib de projet erroné

J'ai une application Android composée de plusieurs projets. L'un de ces projets est un projet d'application qui vient d'étendre l'objet Application. À l'intérieur de build.gradle pour ce projet d'application, j'ajoute d'autres projets en tant que dépendances. Je viens de créer un nouveau module pour loger un SDK (aar) que je veux utiliser. Je l'ai également […]

Erreur de retour de l'API Google Play 401

J'utilise la bibliothèque d' éditeur de gradle-play pour télécharger mon application sur Google Play, mais j'obtiens une erreur 401 non autorisée lors de l'exécution de la tâche de publication. Mon compte dev dans Google Play et le compte de service de Dev Console sont configurés. L'API de lecture est activée. Comme je l'ai vu à […]

Erreur d'erreur "Gradle version 1.10 est nécessaire. La version actuelle est 1.12. "Lors de l'exécution de" gradle wrapper "?

J'essaie d'exécuter gradle wrapper pour un projet Android, et cette erreur est soulevée: Un problème s'est produit lors de l'évaluation du projet racine 'myapp'. > Gradle version 1.10 est requis. La version actuelle est 1.12. Si vous utilisez l'emballage de gradle, essayez d'éditer la distributionUrl dans /Users/dude/myapp/gradle/wrapper/gradle-wrapper.properties à gradle-1.10-all.zip Ma tâche wrapper dans build.gradle ressemble […]

Autorisations sans duplication Manifest Android

Nous disposons d'une application composée d'une bibliothèque tierce (altbeacon), d'une bibliothèque Android développée localement et d'un composant d'application. Les trois composants ont un AndroidManifest.xml qui sont fusionnés lors de la construction. L'application est construite en utilisant gradle. Cette application a été publiée depuis longtemps sur Google Play Store. Au cours de la dernière itération, nous […]

Impossible de filtrer les actifs pour des densités multiples à l'aide des outils de construction SDK 21 ou plus récent

En raison d'un problème lors de la création de ma application en mode édition avec le plugin 1.3.0 de gradle, j'ai changé en 1.4.0 (beta 2), ce qui corrige ce problème de construction. Cependant, alors que certaines saveurs se développent parfaitement, d'autres ont aborté leur construction avec le message d'erreur suivant: Impossible de filtrer les […]

Android Studio ignore – drapeau de la base de données

J'ai un projet, que je veux configurer sur mon ordinateur. Sur un ordinateur il fonctionne, mais avec une ancienne version d'Android Studio 0.4.0 chaque fois que j'utilise 0.5.2 Le problème est qu'après avoir lancé une application, elle montre une erreur Erreur de script de construction, méthode Gradle DSL non prise en charge trouvée: 'coreLibrary ()'! […]

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.