Tag: android gradle

L'application est compilée chaque fois que Gradle s'exécute, prenant un temps considérable

Lorsqu'il se développe avec Eclipse, si j'ai exécuté / débogué une application avant et n'a pas changé son code source, il est raisonnablement rapide d'exécuter / déboguer à nouveau la même application. Cependant, avec Android Studio et Gralde, chaque fois que j'essaie d'exécuter / déboguer une application, la compilation de gradle serait toujours exécutée, en […]

Création de fichiers .so dans Android Studio 1.0.2 avec NDK

J'ai travaillé sur l'obtention d'une application très simple, NDKSample, selon la marche à suivre ici . Mon problème est que je ne peux pas obtenir Android Studio pour générer les fichiers .so, donc je n'ai pas de bibliothèques. Je comprends que NDK Support est obsolète maintenant et il y aura une alternative fournie au début […]

Android Studio: Impossible de supprimer le fichier original

Je suis très nouveau sur Android et j'ai récemment clone un projet Android. Lorsque Android Studios effectue l'indexation une fois l'ouverture du projet, je reçois cette erreur tout le temps. C'est l'erreur que je reçois d'Android Studio. Error:(89, 0) Failed to delete original file 'C:\Users\myname\AppData\Local\Temp\gradle_download8065263342645015068bin' after copy to 'C:\Users\myname\.gradle\caches\modules-2\files-2.1\com.android.tools.build\gradle\1.5.0\1c3d2b23212349ffbe6479fcb04732c5cddaf98b\gradle-1.5.0.pom' <a href="openFile:D:\myname\mobile-myapp-tester\platforms\android\build.gradle">Open File</a>

Projet d'unité en tant que dépendance à Gradle

J'essaie d'importer un projet unit3d dans mon projet Android comme module. Tout est correct, la synchronisation de gradle finit sans erreur, mais quand j'ajoute un projet d'unité en tant que dépendance à mon projet et que j'exécute la synchronisation de gradle, il dit: Error:Dependency myapplication:unityproject:unspecified on project app resolves to an APK archive which is […]

L'exécution instantanée ne fonctionnera pas sur Android Studio, indique que Gradle version 2.10 est nécessaire. J'utilise 2.10

C'est l'erreur que je reçois: Error:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in /Users/alinrosu/Workspace/passenger-android/gradle/wrapper/gradle-wrapper.properties to gradle-2.10-all.zip J'utilise ceci dans mon buildscript: dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha5' } Voici mon fichier gradle-wrapper.properties: #Tue Jan 05 13:28:23 CET 2016 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip Comme vous pouvez […]

Android Plusieurs fichiers dex définissent Lcom / google / android / gms / common / api / zza

Le projet de construction et le déploiement de l'application sur l'émulateur avec les niveaux 22 ou 25 de l'API vont bien, mais lorsque j'essaie de créer APK ou de déployer une application sur mon véritable périphérique avec le niveau API 16, j'ai l'erreur suivante: Error:Execution failed for task ':app:transformClassesWithDexForDebug'. > com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.dex.DexException: Multiple […]

Ensemble de test pour différentes saveurs dans Android Studio

J'expérimente des saveurs sur une application dans androidstudio. Je dois écrire différentes classes de test pour les saveurs, car j'ai des fichiers de classe différents pour les saveurs. Mais je me demande s'il existe une option pour spécifier des paquets de test pour chaque saveur dans build.gradle. Voici mon build.gradle à titre de référence. J'utilise […]

N'a pas pu trouver gradle 3.0.0-alpha4

Il y a quelques jours, j'ai installé android studio 3.0 (prévisualisation) et après cela dans la version stable (studio 2.3.3) lorsque j'essaie d'importer un projet, il me donne une erreur. Dans l'aperçu, tout fonctionne bien. C'est une erreur: Error:Could not find com.android.tools.build:gradle:3.0.0-alpha4. Searched in the following locations: file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/3.0.0-alpha4/gradle-3.0.0-alpha4.pom file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/3.0.0-alpha4/gradle-3.0.0-alpha4.jar https://jcenter.bintray.com/com/android/tools/build/gradle/3.0.0-alpha4/gradle-3.0.0-alpha4.pom https://jcenter.bintray.com/com/android/tools/build/gradle/3.0.0-alpha4/gradle-3.0.0-alpha4.jar […]

Erreur: Impossible de résoudre: com.google.android.gms: play-services-measurement: 9.2.0

Après la mise à niveau du service Google Play au 9.2.0, je reçois cette erreur lors d'une synchronisation de gradle. Error:Failed to resolve: com.google.android.gms:play-services-measurement:9.2.0 Comment puis-je résoudre ceci?

Problèmes dont Apache HttpComponents dans le projet Android Gradle

J'essaie d'inclure httpmime dans ma application en utilisant le fichier build.gradle, et tout se compose bien. Au lieu de cela, lorsque l'application essaie d'utiliser réellement la classe MultipartEntityBuilder, plusieurs messages de niveau WARN sur le journal indiquent qu'il y a des problèmes. Voici l'extrait de mon build.gradle pour la dépendance: Compile ('org.apache.httpcomponents: httpmime: 4. +') […]

coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.