Android Studio 2.2. Aperçu 1 erreur: "Utilisez JDK 8 ou plus récent"

En essayant d'exécuter Android Studio 2.2 Preview 1, il donne l'erreur suivante sur la compilation gradle:

Erreur: utilisez JDK 8 ou plus récent.

  • Pourquoi devrais-je utiliser un fragment dans Android?
  • Autoriser l'instabilité d'Android Gradle sur Jenkins
  • EditText afterTextChanged ne fonctionne pas
  • Capture de caméra Android utilisant FFmpeg
  • Le dossier «données» du moniteur de périphérique Android est vide
  • Lock Auth0 pour Android ne retourne pas UserProfile sur l'authentification
  • Si je tente de le faire depuis la console, il dit:

    FAILURE: la compilation a échoué avec une exception.

    • Où: Créez un fichier 'C: \ Coding \ Projets Android \ MaterialScrollBar \ app \ build.gradle' line: 1

    • Ce qui a mal tourné: un problème s'est produit en évaluant le projet ': app'. Com / android / jack / api / ConfigNotSupportedException: Major.minor version 52.0 non prise en charge

    J'ai essayé de changer le JDK tel qu'il le suggère de jdk 1.7 à 1.8, mais chaque fois que je change l'emplacement JDK pour le projet vers un autre chemin que celui qu'il contient actuellement, il réinitialise immédiatement. Même si je le modifie sur d'autres versions de 1.7, cela ne changera pas.

    J'ai vérifié que les variables environnementales indiquent 1.8 et ne contiennent toujours aucun dés. AS 2.1 reconnaît le JDK comme 1.8 pour le même projet.

  • Populating Android Spinner avec la liste des objets
  • Ressources $ NotFoundException: La ressource n'est pas un dessinable (couleur ou chemin)?
  • Mettre à jour le plugin Android Studio Gradle vers la dernière version
  • Problème de répertoire racine du projet Android Test dans Eclipse
  • Comment faire pour activer le Gestionnaire de téléchargement d'Android
  • ListFragment onPrepareOptionsMenu appelé avant onCreate. Pourquoi et comment réparer / contourner?
  • 4 Solutions collect form web for “Android Studio 2.2. Aperçu 1 erreur: "Utilisez JDK 8 ou plus récent"”

    J'ai rencontré ce problème avec une version précédente d'Android Studio. Lorsque j'ai installé Android Studio, j'ai pu faire une référence à JDK 7 dans mon répertoire Program Files.

    Lorsque j'ai mis à niveau Android Studio et essayé de le mettre à jour pour pointer vers JDK 8, qui était également dans mon répertoire Program Files, j'ai le même comportement que vous voyez. Le nouveau chemin n'a jamais pris et il a toujours utilisé JDK 7.

    Résultat Android Studio n'aime pas les espaces dans les chemins d'accès au SDK Android et au JDK. L'installation du JDK dans un emplacement qui ne contient aucun espace m'a permis de mettre à jour l'emplacement via la fenêtre Structure du projet.

    Si vous utilisez Android Studio 2.2 Preview 2 et que vous avez la même erreur, vérifiez "Utiliser JDK intégré" dans l'emplacement SDK. Utiliser JDK intégré

    Assurez-vous de le définir dans la structure du projet

    Utilisez le fichier -> Structure du projet pour définir le SDK et JDK. Je pense que vous modifiez un fichier généré.

    Essayez également d'ajouter ceci dans votre fichier gradle:

     compileOptions { sourceCompatibility JavaVersion.VERSION_1_7 targetCompatibility JavaVersion.VERSION_1_7 } 

    Oui, je suis tout à fait d'accord avec Episodex. Mais encore, le problème se produirait, faites comme décrit ci-dessous, cliquez sur le menu Fichier en haut du coin de gauche et sélectionnez un menu de Invalidate caches / Restart … Entrez la description de l'image ici

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.