Android: Import DrawerLayout ne peut pas être résolu

J'essaie d'importer les classes requises pour utiliser le nouveau "Drago de navigation" d'Android http://developer.android.com/design/patterns/navigation-drawer.html#ImpactOnNav

DrawerLayout: http://developer.android.com/reference/android/support/v4/widget/DrawerLayout.html

  • Maintenez le clavier doux ouvert lorsque la touche Entrée est enfoncée
  • Partagable rencontré IOException écriture sérialisable objet gétactivity ()
  • L'importation android.support.v7 ne peut pas être résolu
  • Android / java getIdentifier with
  • Comment puis-je ajouter selectableItemBackground à un ImageButton par programme?
  • Définir les limites de date de date de départ Android
  • ActionBarDrawerToggle: http://developer.android.com/reference/android/support/v4/app/ActionBarDrawerToggle.html

    L'importation android.support.v4.widget.DrawerLayout ne peut pas être résolu L'importation android.support.v4.app.ActionBarDrawerToggle ne peut pas être résolu

    J'ai mis à jour les bibliothèques sur la dernière version, mais ces classes ne sont pas reconnues.

  • Transparent status-bar / system-ui sur 4.4 Kit Kat
  • Comment limiter l'édition d'Android du champ de texte uniquement pour certains caractères sélectionnés
  • OnPostExecute n'est pas appelé dans AsyncTask (exception Runtime du gestionnaire)
  • Juste mis à niveau mon OS X sur Yosemite, Android Device Chooser ne montrant aucun périphérique - que faire?
  • Test Android AsyncTask avec Android Test Framework
  • Essai d'intention d'espresso échoué
  • 3 Solutions collect form web for “Android: Import DrawerLayout ne peut pas être résolu”

    Comment puis-je mettre à jour les JAR dans les bibliothèques?

    Je le fais habituellement en copiant le fichier. Vous trouverez les JAR à l'intérieur de $ANDROID_SDK/extras/android/support , où $ANDROID_SDK est là où votre SDK Android est installé.

    Si vous utilisez Eclipse, si vous copiez cela au niveau du système de fichiers, et Eclipse est ouvert, appuyez sur <F5> avec le projet mis en surbrillance dans le Gestionnaire de paquets afin que Eclipse reprenne les modifications. Plus simple est de le faire sortir du SDK et de déposer le JAR dans libs/ right dans Eclipse, qui mettra à jour le système de fichiers et laisse Eclipse connaître le changement.

    Il est possible que l'option Eclipse pour ajouter les JAR (clic droit sur le projet, puis choisir Outils Android> Ajouter une bibliothèque de support … dans le menu contextuel) fera également cela. Cette approche particulière ne fonctionne pas pour moi en raison de certaines particularités de mon environnement de développement.

    Copiez le support jar du SDK d'Android dans votre dossier libs. Devrait être dans <ANDROID SDK FOLDER>\extras\android\compatibility\v13 .

    Dans le studio Android, j'ai constaté que l'ajout de dépendances résolvait le problème.

    Dans le menu du fichier, recherchez la structure du projet. Sous «application», recherchez l'onglet dépendances. Cliquez sur le vert plus sur le côté droit. Sélectionnez la dépendance de la bibliothèque.

    J'ai ajouté les deux support-v4 et support-v13.

    coAndroid est un fan Android de Google, tout sur les téléphones Android, Android Wear, Android Dev et Android Games Apps.